Server Apache immagine not found (ERROR 404)

andrea duregon

Nuovo Utente
6 Mar 2020
3
0
1
Buongiorno!
Sto sviluppando un sito web per un progetto universitario utilizzando Apache come server. Quando provo ad eseguire in locale, però, la pagina viene caricata correttamente, eccetto che per le immagini. Nello specifico, in console, mi da il seguente errore:

Failed to load resource: the server responded with a status of 404 (Not Found)

con il riferimento all'immagine che ho provato ad inserire.
Non è sicuramente un problema di PATH, scritto correttamente; non è un problema legato al posizionamento della directory immagine, inserita nella DOCUMENT ROOT definita per il server; non è un problema di permessi sulle directory o sui file, avendo già dato tutti i permessi possibili a tutti gli utenti possibili.

Altre infromazioni che potrebbero essere utili:
Versione APACHE: 2
Versione PHP: 7.2.8
Sto utilizzando Smarty come template engine.

Qualcuno ha qualche idea sul come risolvere questo problema???
Grazie!
 

mr.x

Utente Attivo
9 Apr 2016
250
25
28
Non è sicuramente un problema di PATH, scritto correttamente; non è un problema legato al posizionamento della directory immagine, inserita nella DOCUMENT ROOT definita per il server; non è un problema di permessi sulle directory o sui file, avendo già dato tutti i permessi possibili a tutti gli utenti possibili.
Prova a ricontrollare il percorso.. e dal momento che qui nessuno è veggente, magari prova a postare il codice della pagina che magari qualcuno vede qualcosa che ti sfugge.

Nel frattempo, come test, se stai utilizzando un path relativo per caricare l'immagine, fai una prova utilizzando il path assoluto e vedi se così funziona.
 

andrea duregon

Nuovo Utente
6 Mar 2020
3
0
1
Prova a ricontrollare il percorso.. e dal momento che qui nessuno è veggente, magari prova a postare il codice della pagina che magari qualcuno vede qualcosa che ti sfugge.

Nel frattempo, come test, se stai utilizzando un path relativo per caricare l'immagine, fai una prova utilizzando il path assoluto e vedi se così funziona.
Ho provato ad allegare il codice ma non lo carica. Comunque, il codice è il seguente:

<img src="/Applications/MAMP/htdocs/ProgettoDef/immagini/logohp.png" />

Per quanto riguarda PATH relativo/assoluto, ho provato in tutte le maniere, ma da sempre lo stesso risultato.
Altre idee???
 

mr.x

Utente Attivo
9 Apr 2016
250
25
28
Codice:
<img src="./immagini/logohp.png" />
considerando che la cartella immagini sia nella stessa directory dove è il file in cui è scritto il precedente codice

Codice:
<img src="http://localhost:8000/ProgettoDef/immagini/logohp.png" />
ipotizzando che mamp stia in ascolto sulla porta 8888
 
  • Like
Reactions: andrea duregon

Max 1

Super Moderatore
Membro dello Staff
SUPER MOD
MOD
29 Feb 2012
4.235
322
83
@andrea duregon
Il codice non si deve allegare!!!! Il codice va scritto all'interno degli appositi tag a secondo del tipo di codice

Prima di continuare sul forum sei tenuto e devi leggere assolutamente il regolamento generale e quello della sezione dove posti!
Mi taccomando