[WordPress] Errore di connessione: si apre solo la home page e senza grafica

Magenta

Nuovo Utente
Salve,

provo ad installare file di vecchio backup del mio sito su xamp, i dati messi su wp-config.php mi sembrano giusti, ed in effetti la home page appare, ma i link non sono cliccabili, e la grafica non viene richiamata.

Vorrei chiedere gentilmente se l'errore riguarda in effetti un errato collegamento con il database.
 

glm2006ITALY

Moderatore
Membro dello Staff
MOD
9 Apr 2009
1.253
10
38
33
Vercelli
www.webepc.it
Non è che, per caso, sei su Aruba e ti sei scordata di rinnovare il servizio di database MySQL?
 

Magenta

Nuovo Utente
L'hosting è tutto ok.

Sto facendo delle prove sul server locale, è qui che ho problemi, non ne ho invece se installo WordPress ex novo. Mi sembra di avere seguito la stessa procedura, l'unico dubbio è che avendo importato il database in formato zip, 900 KiB circa, non lo caricavo se prima non creavo una cartella in cui metterlo. Cioè non lo importo direttamente, temo che sia al mio solito un problema di percorso.
 

glm2006ITALY

Moderatore
Membro dello Staff
MOD
9 Apr 2009
1.253
10
38
33
Vercelli
www.webepc.it
Uhm... mi sono perso qualcosa.

Se ti da pagina bianca, a questo punto, potrebbero essersi corrotti dei file: prova a ricaricare i file di installazione di WP!
 

Magenta

Nuovo Utente
La pagina non è proprio bianca, vedo in fila verticare tutti articoli e i menù, anche se leggo nel browser pagina non trovata. Poi se clicco su una delle voci di menù il link è inattivo.

Ho cancellato la cache ogni volta che tento la visualizzazione, altrimenti mi richiama il sito in remoto.

Perdona la mia impreparazione, vuoi dire di lasciare perdere quel backup, oppure di sovrapporre qualcosa ? Grazie per le risposte
 
Ultima modifica:

_SAGO

Nuovo Utente
8 Gen 2017
2
0
1
33
Rome
Provo a farti una domanda...magari è scontata ma io ci provo lo stesso...hai sostituito il path assoluto del dominio con quello locale all'interno del db...?
 

Magenta

Nuovo Utente
Ciao _SAGO,


Ho solo cambiato nome user e password del database in wp-config.php.

Se creo il file che chiamo path.php con la stringa :

Codice:
<?php
echo  $_SERVER["DOCUMENT_ROOT"];
?>
e digito nel browser http:// localhost/miosito.it/path.php

trovo che il percorso assoluto è : C:/xampp/htdocs

C'entra qualcosa?

In wp-config.php alla fine trovo riferimento alla path nelle ultime righe, ma non so se devo cambiare qualcosa.

Codice:
/** WordPress absolute path to the Wordpress directory. */
if ( !defined('ABSPATH') )
   define('ABSPATH', dirname(__FILE__) . '/');

/** Sets up WordPress vars and included files. */
require_once(ABSPATH . 'wp-settings.php');

Grazie per la risposta.
 
Ultima modifica: