Tag VIDEO, come mai il formato "webm" funziona solo su Chrome?

Donovant

Utente Attivo
24 Giu 2010
49
0
0
Come da titolo.... dovrebbe funzionare anche su FF dalla versione 4 in poi e su Safari dalla 5 in poi, ma invece...
PHP:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> 
<html xmlns="http://www.w3.org/1999/xhtml"> 
<head> 
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> 
<title>Untitled Document</title> 
</head> 

<body> 

<video id="video1" width="640" height="360" autoplay loop > 
   <source src="your-v.webm" type="video/webm" /> 
</video> 

<video id="video2" width="640" height="360" autoplay loop > 

    <source src="http://videos-cdn.mozilla.net/serv/marketing/firefox4/FF4_Jess3Features_VO_1.webm" type="video/webm" /> 
</video> 

</body> 
</html>
In Chrome funzionano tutti e DUE (sono lo stesso file e filmato ma con nomi diversi), mentre in FireFox NO?????????????????????

Grazie
 

Donovant

Utente Attivo
24 Giu 2010
49
0
0
Tante visite nessun commento...ho scritto qualcosa che non va, sono stato poco chiaro o cos'altro???
 

Trogo

Utente Attivo
11 Gen 2008
370
0
0
39
Sanremo
Io l'ho provato con FF 4.0.1 su Ubuntu e funziona senza problemi, anche in fullscreen
 

Donovant

Utente Attivo
24 Giu 2010
49
0
0
SIGGGGGGGGGGGGGGGGGGH!
Non capisco i file sono gli stessi ma con come ed ovviamente path diverso, quello linkato con un path online funziona, il PRIMO no... o_O''
 

Donovant

Utente Attivo
24 Giu 2010
49
0
0
Qualcuno mi può dire se visualizza qualcosa qui???? Un'animazione piccola e corta?
animazione

Perchè in locale la visualizzo benissimo mentre online nada de nada?

Grazie :(
 

Donovant

Utente Attivo
24 Giu 2010
49
0
0
Anche io lo pensavo, ma purtroppo non è così, il file c'è, è nella cartella specificata...non riesco a raccappezzarmi.
 

Donovant

Utente Attivo
24 Giu 2010
49
0
0
Anche questo l'ho fatto. Il file può essere letto, non ci capiscopiù nulla....mi sembra tutto un paradosso, sul pc funziona alla perfezione o_O''
 

Trogo

Utente Attivo
11 Gen 2008
370
0
0
39
Sanremo
Non ricordo bene dove, ma in IIS bisogna specificare le estensioni dei file che possono essere "serviti". E di sicuro .wbem non è tra quelle di default.
 

Trogo

Utente Attivo
11 Gen 2008
370
0
0
39
Sanremo
In pratica devi aprire l'IIS Manager, andare sulle Proprietà del sito web, aprire la scheda "HTTP Headers", cliccare su "MIME/Types". Nella finestra che si apre clicchi su "New" e poi come estensione inserisci "webm" e come MIME "video/webm".

Ovviamente devi avere accesso al server per poterlo fare oppure chiedere a chi ti fornisce l'hosting di configurarlo.
 

Donovant

Utente Attivo
24 Giu 2010
49
0
0
Come si accede all'IIS Managare, dal sito del gestore del webserver?
Nel mio caso Aruba?
 

Trogo

Utente Attivo
11 Gen 2008
370
0
0
39
Sanremo
Per aprire l'IIS Manager devi avere accesso al server in Desktop Remoto. Ma per fare questo dovresti avere un server dedicato su Aruba, e non mi sembra il tuo caso.