problemi di connessione al db con il nuovo phpmyadmon 4.1.12

paperinik4

Utente Attivo
29 Mag 2011
1.812
0
36
Roma
www.ricetteagogo.it
Salve a tutti,

Ho un grosso problema da cui non riesco a venirne a capo. Allora ieri ho installato il phpmyadmin 4.1.12 Con molta fatica sono riuscito ad entrare e a modificare i vari settaggi, tra cui anche la password. Fino qui tutto ok. SOno andato ad adoperare il mio vecchi file connetti.php e mi dice che non riesce a connterrsi al db. premetto che ho creato un mio account e dato tutti i privileggi. ora se digito le stesse credenziali che ho messo per accedere a phpmyadmin riesco ad entrare, se faccio girare connetti mi da errore vorrei capire dove diavolo sbaglio. per ragioni di privacy e sopratutto di sicurezza tolgo password e host. Questo è il mio file connetti.php

connetti.php

PHP:
<html>
        <head>
            <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
</html>
</head>

<?php
 $ip = $_SERVER['SERVER_ADDR'];
 
if(substr($ip,-7,3) == '150'){    

$host     = 'ind nas';
$user     = 'fabio';
$password = 'xxxx';
$DB_name     = 'MegaLaboratorio';

$link = mysql_connect($host, $user, $password);
if (!$link) {
	die ('Non riesco a connettermi: ' . mysql_error());
}

$db_selected = mysql_select_db($DB_name, $link);
if (!$db_selected) {
	die ("Errore nella selezione del database: " . mysql_error());
}
else
      {
         
    echo'<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">';
    
//echo "Ti sei connesso al database"." ". $DB_name. " "."Sei connesso da Roma.... Complimenti"." "."Il tuo indirizzo ip del server è:"." ". $ip;
}
  
}


else if(substr($ip,-7,3) == '168'){

    
    $host     = 'ind nas';
$user     = 'fabio';
$password = 'xxxx';
$DB_name     = 'MegaLaboratorio';

$link = mysql_connect($host, $user, $password);
if (!$link) {
	die ('Non riesco a connettermi: ' . mysql_error());
}

$db_selected = mysql_select_db($DB_name, $link);
if (!$db_selected) {
	die ("Errore nella selezione del database: " . mysql_error());
}
else
      {
         
    echo'<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">';
    
//echo "Ti sei connesso al database"." ". $DB_name. " "."Sei connesso da Anzio.... Complimenti"." "."Il tuo indirizzo ip del server è:"." ". $ip;
}
  
}
?>
L'errore che mi viene visualizzato è alla seguente riga la isolo:

PHP:
$link = mysql_connect($host, $user, $password);
Spero che qualcuno mi possa aiutare grazie.

P.S.: Le credenziali sono sicuro che siano quelli altrimenti non riuscire nemmeno ad entrare in phpmyadmin.