Problema invio e-mail (era: problemi con xoom)

Angel0

Nuovo Utente
20 Mar 2010
13
0
0
www.instantempo-2010.it
ciao a tutti,
sono nuovo da queste parti. gestisco da poco un piccolo sito web con xoom, ho iniziato a crearlo con il wizard, fin qui tutto ok. adesso morrei mettere online un sito più carino che sto preparando.
sto cercando di creare un formmail in php, inizialmente andava, ma adesso non ricevo più le mail... se lo stesso formmail lo carico su altervista tutto funziona regolarmente!!!
avete dei consigli o sapete da cosa può dipendere???
grazie
 

alessandro1997

Utente Attivo
6 Ott 2009
5.302
1
0
22
Roma
alessandro1997.netsons.org
Non è sicuro perché sarebbe meglio così:
PHP:
<?php
$nome = isset($_POST['nome']) ? trim($_POST['nome']) : '';
$testo = isset($_POST['testo']) ? trim($_POST['testo']) : '';
$email = isset($_POST['email']) ? trim($_POST['email']) : '';

if($nome == '')
    die('Non hai inserito il tuo nome.');
if($testo == '')
    die('Non hai inserito il messaggio.');
if(!filter_var($email, FILTER_VALIDATE_EMAIL))
    die('Non hai inserito una e-mail valida.');

$dest = "xxxx@gmail.com";
mail($dest,$nome,$testo,$email);

header('Location: pagina.php');
?>
Ovviamente devi cambiare l'indirizzo nell'ultima riga con quello della pagina a cui vuoi reindirizzare l'utente.
 

Angel0

Nuovo Utente
20 Mar 2010
13
0
0
www.instantempo-2010.it
Caricando il file come dici tu, ovviamente cambiando mail e pagina di destinazione mi da errore.. devo aggiungere qualcosa?
Questi trim che mi hai inserito tu servono per avere il controllo sul capo?
io ho già il controllo del campo nel file html.


lo staff di xoom dice che non è cambiato nulla nei loro servizi, mi consiglia di controllare il mio codice php. In particolare gli header... Cioè? Non capisco...

Grazie per la disponibilità