PHPMAILER e UMLAUTS (lettere tedesche äüäöß)

angus

Nuovo Utente
25 Mar 2018
2
0
1
57
Buongiorno al forum,

ho un sito web con un "contact form" dove I clienti possono inserire delle richieste di prenotazione per il nostro ristorante (sono in Austria).
Dal momento che ho spostato il sito ed il dominio su un nuovo provider ho iniziato ad avere problemi con le lettere tedesche:
In qualsiasi campo sia presente una di queste lettere (Nome, Soggetto, Messaggio) io ricevo la email ma il campo arriva vuoto., e solamente "quel" campo mentre tutto il resto e' leggibile.
Non ho nessuna esperienza com sviluppatore web ma ho esperienza come sysadmin...nonostante varie ricerche non trovo una soluzione ed avrei bisogno di un gentile aiuto!!
Ringrazio e pubblico qui sotto il file che gestisce il form:
PHP:
<?php
    function decodeval($str){
      
        return nl2br(htmlentities(utf8_decode(($str))));
    }
  
    require 'lib/mailer/PHPMailerAutoload.php';
    $mail = new PHPMailer;
    $valid = false;
    if(isset($_POST['fname']) && isset($_POST['fmail']) && isset($_POST['fphone']) && isset($_POST['fmsg'])){
        $valid = true;
    }
    $name = decodeval($_POST['fname']);
    $email = decodeval($_POST['fmail']);
    $phone = decodeval($_POST['fphone']);
    $msg = decodeval($_POST['fmsg']);
    $subject = $_POST['fsubject'];
  
    $message = <<<EMAILMSG
        <div style="font-family: Arial, sans-serif">
            <table>
                <tr>
                    <th>Name</th>
                    <td>$name</td>
                </tr>
                <tr>
                    <th>E-Mail</th>
                    <td>$email</th>
                </tr>
                <tr>
                    <th>Telefon</th>
                    <td>$phone</td>
                </tr>
            </table>
            <p>$msg</p>
        </div>
EMAILMSG;
    $mail->From = $email;//'test@test.at';
    $mail->FromName = 'Anfrage Website';
  
    //$mail->addAddress('patrick@electrophanteau.com');
    $mail->addAddress('p.santner@test.at');
    //$mail->addAddress('l.ainz@retest.at');
    $mail->addAddress('office@example.at');
    $mail->isHTML(true);
    $mail->CharSet = "UTF-8";
    $mail->Subject = $subject;
    $mail->Body    = $message;
    //$mail->AltBody = 'This is the body in plain text for non-HTML mail clients';
  
    if($valid){
        if(!$mail->send()) {
            echo 'Message could not be sent.';
            echo 'Mailer Error: ' . $mail->ErrorInfo;
        } else {
            echo 'Message has been sent';
        }
    }
 
Ultima modifica di un moderatore:

Max 1

Super Moderatore
Membro dello Staff
SUPER MOD
MOD
29 Feb 2012
4.087
299
83
@angus
Da regolamento del forum, come tutti noi sei tenuto ad usare il tag
code.gif
quando posti del codice, oppure la funzione codice dalla barra degli strumenti
box inserisci 2.png.JPG

Inoltre ti prego di leggere attentamente il regolamento generale del forum e quello di sezione dove posti
Grazie
Per questa volta te lo sistemo io ma mi raccomando per il futuro
 

angus

Nuovo Utente
25 Mar 2018
2
0
1
57
@Max 1 grazie e scusa (scusate) per gli errori. Sono appena arrivato in questo forum in cerca di una soluzione e. come sempre gli ultimi arrivati con una certa urgenza, non si riesce ad avere abbastanza tempo per leggere bene tutti I regolamenti . Ringrazio per la pazienza e spero di avere un riscontro su questo problema