[PHP] collegarsi a DB con XAMP

keyboardistdenny

Utente Attivo
30 Ago 2013
40
0
6
roma
Salve sto nuovamente lavorando con Php, ambiente XAMP,
ho realizzato database con il phpmyadmin fornito da XAMP, ora
come faccio a collegarmi al DATABASE ? Funzionano ancora @mysql_connect e @mysql_select_db?
 

keyboardistdenny

Utente Attivo
30 Ago 2013
40
0
6
roma
Nn ho mysqli, a me occorre sapere in quale cartella trovare il db che ho realizzato con phpmyadmin e come richiamarlo da pagina php..mi trovo bene con mysql
 

Max 1

Super Moderatore
Membro dello Staff
SUPER MOD
MOD
29 Feb 2012
4.083
299
83
Senza preoccuparti dove sta il database ti dovrebbe bastare mettere nella cartella htdocs il tuo file php con il codice
PHP:
// hostname
$nomehost = "localhost";   
// utente per la connessione a MySQL 
$nomeuser = "username";
// password per l'autenticazione dell'utente
$password = "password";
// connessione tramite mysql_connect()
$connessione = mysql_connect($host,$user,$pass);
per collegarti al database.
Ovvio che devi sostituire il nome la pass ecc. con i tuoi dati
 

macus_adi

Utente Attivo
5 Dic 2017
1.141
65
48
IT/SW
Ti consiglio l'uso di PDO e estensione mysqli in quanto mysq_connect viene supportata ma deprecata. Potresti fare il salto di qualità, ne gioverà sia l'applicazione che l'esecuzione delle query.

Leggi qui! mysql_connect è uscito con la versione php 4.0 nel 2001, forse negli anni qualcosa è cambiato.....

Personalmente trovo queste tipologie di connessioni molto arrangiate, nel 2018 è impensabile utilizzare un metodo vecchio di 17 anni e deprecato! (tabella release non supportate)
 

keyboardistdenny

Utente Attivo
30 Ago 2013
40
0
6
roma
eh si ma perché la deprecate? questione di sicurezza? sono funzioni che fanno la stessa cosa almeno rimanessero con lo stesso nome ..non sono esperto
cmq mi esce
Uncaught Error: Call to undefined function mysql_connect() in C:\xampp\htdocs\dashboard\pagina1.php
 

macus_adi

Utente Attivo
5 Dic 2017
1.141
65
48
IT/SW
Perchè cambiano i modelli delle auto? La stessa logica....
Che versione hai di php??? se hai la 7 non funziona!
 

keyboardistdenny

Utente Attivo
30 Ago 2013
40
0
6
roma
esatto ho installato la 7 ,
funziona se installo php5 su htdocs o devo reinstallare XAMP con la versione php5 ? vorrei tenere sia php5 per sviluppo immediato e sia php 7 per potermelo studiare che mi consigliate?
 
Autore Discussioni simili Forum Risposte Data
moustache PHP 1
G PHP 0
V PHP 0
L PHP 1
M PHP 1