Mancata visualizzazione di icone su button

Luca Ambrosini

Nuovo Utente
17 Dic 2019
14
1
3
Un caloroso saluto a tutto il forum.
Sono Luca e mi sono iscritto da poco perchè vorrei, dico "vorrei" realizzare una piccola applicazione web da utilizzare nell'ambito dell'ufficio per la gestione delle richieste di cancelleria da parte degli uffici al ns servizio magazzino che si preoccupa dell'approvvigionamento e della distribuzione degli stessi con operazioni di carico e scarico della merce.

Premetto
- che ho realizzato questo tipo di applicazione in Access e funziona correttamente, ma sono nate nuove necessità che mi hanno spinto a cercare di realizzarla come applicazione web.
Premetto che l'applicazione che cerco di realizzare non ha scopo di lucro (non remunerata in nessun caso) e la faccio per pura passione per la programmazione.
- che l'approccio a HTML e PHP e a MYSQL è da autodidatta, quindi non ho una conoscenza dei linguaggi. Ho visionato diversi codici e varie demo ... cercando di capire, anche con l'aiuto di guide di questo form (fatte molto bene).
Fatte le premesse del caso vi espongo il problema di oggi.
Con l'aiuto di un esempio pratico, per la gestione degli articoli, ho creato base dell'applicazione con la connessione ad dbase degli articoli.
la pagina iniziale (index.php) è la seguente:
PHP:
<!DOCTYPE html>

<html>
<head>

<title>gestione magazzino economale</title>
<script src="jquery.min.js"></script>
<link rel="stylesheet" href="bootstrap.min.css" />
<script src="bootstrap.min.js"></script>
<link rel="stylesheet" href="jquery.dataTables.min.css"></style>
<script type="text/javascript" src="jquery.dataTables.min.js"></script>
<script type="text/javascript" src="bootstrap-filestyle.min.js"> </script>
<link href="fonts.css" rel="stylesheet">


<script>

$(document).ready(function(){
$('#empTable').dataTable();
$('.file-upload').file_upload();
});

</script>
</head>

<body style="margin:20px auto">
<center>
<h2><span style="font-size:25px; color:blue">
Magazzino - Elenco Articoli</span>
</h2></center>

<div class="container">
<br/><br/>
<div class="row header col-sm-12" style="text-align:center;color:green">
<span class="pull-left">
<a href="#addnew" data-toggle="modal" class="btn btn-primary btn-sm">
<span class="glyphicon glyphicon-plus"></span> Aggiungi articolo
</a></span>

<div style="height:50px;"></div>
<table class="table table-striped table-bordered table-responsive table-hover"
id="empTable" >
<thead>
<th><center>id</center></th>
<th><center>Cod. Art.</center></th>
<th><center>Descrizione articolo</center></th>
<th><center>U.M.</center></th>
<th><center>Giac.</center></th>
<th><center>Action</center></th>
</thead>
<tbody>
<?php
include('database.php');
$result=$mysqli->query("select * from employee_basics");
while($row=$result->fetch_assoc()){
//$img = "http://localhost/php_crud/profile_images/".$row['id']. ".jpg";
?>
<tr>
<!--d> <img src='<?php echo $img ?>' height="50px" width="70px" /></td-->
<td><?php echo $row['id']; ?></td>
<td><?php echo $row['name']; ?></td>
<td><?php echo $row['address']; ?></td>
<td><?php echo $row['post']; ?></td>
<td><?php echo $row['phone']; ?></td>
<td>
<a href="#detail<?php echo $row['id']; ?>"
data-toggle="modal" class="btn btn-success btn-sm">
<span class="glyphicon glyphicon-floppy-open">
</span></a>&nbsp;

<a href="#edit<?php echo $row['id']; ?>"
data-toggle="modal" class="btn btn-warning btn-sm">
<span class="glyphicon glyphicon-edit">
</span></a>&nbsp;

<a href="#del<?php echo $row['id']; ?>"
data-toggle="modal" class="btn btn-danger btn-sm">
<span class="glyphicon glyphicon-trash">
</span></a>

<!-- include edit modal -->
<?php include('show_detail_modal.php'); ?>
<!-- End -->
<!-- include edit modal -->
<?php include('show_edit_modal.php'); ?>
<!-- End -->
<!-- include delete modal -->
<?php include('show_delete_modal.php'); ?>
<!-- End -->
</td>
</tr>
<?php } ?>
</tbody>
</table>
</div>
<!-- include insert modal -->
<?php include('show_add_modal.php'); ?>
<!-- End -->
</div>
</body>
</html>
</html>
il codice mi restituisce questo risultato:
ListaArticoli.PNG

La mia domanda è questa, come mai nonostante abbia seguito le istruzioni ed adattato il codice alle mie necessità le icone delle azioni non vengono visualizzate correttamente?
Come posso allineare a sx la descrizione degli articoli?
Ringrazio chiunque vuole aiutarmi nello sviluppo di questo progetto.
Un saluto
Luca