Links non accettato con xml per i Feed Rss

mimmoby

Utente Attivo
8 Feb 2005
30
0
0
52
www.mbyweb.eu
Salve sono Mimmo il webmaster del sito www.ceglieincucina.com

Chi mi può aiutare a capire come mai non mi da il link alla ricetta con il files xml per i feed rss? script prelevato dal vostro sito e realizzato da Luca Ruggiero.

Da premettere che i link sono di natura asp, vi do una dimostrazione come e composto:

Così non funziona:
http://www.ceglieincucina.com/ita/ricette/ricetta.asp?iData=262&iCat=78

Se invece li do questo tipo di links come categoria della ricetta mi funziona:

Così funziona.
http://www.ceglieincucina.com/ita/ricette/cat.asp?iCat=78

quindi deduco credo! che il problema sia dovuto solo quando devo dargli questo tipo di link con il segno & mostratovi sopra, altrimenti tutto il resto dei link senza questo segno posso tranquillamente dargli il collegamento ipertestuale.

Grazie per il vostro aiuto.
 

mimmoby

Utente Attivo
8 Feb 2005
30
0
0
52
www.mbyweb.eu
Ok mi spiego meglio visto la mia inesperienza con xml.

O messo sul mio sito un file xml per feed rss ci sei, per dare le news agli utenti.

Ecco il codice:
Codice:
<?xml version="1.0" encoding="ISO-8859-1"?>
<rss version="2.0" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:content="http://purl.org/rss/1.0/modules/content/">
 <channel>
  <title>Ultime ricette inserite</title>
  <link>http://www.ceglieincucina.com/ita/ricette/ricetta.asp?iData=262&iCat=78</link>
  <description>Le migliori ricette dell'alto salento dagli antipasti ai dolci tanti piatti gustosi e ricette facili da cucinare.</description>
  <language>it</language>
  <lastBuildDate>09/11/2009 13.06.54</lastBuildDate>
  <image>
   <url>http://www.ceglieincucina.com/public/icone/logo_rss.png</url>
    <title>Ultime ricette inserite</title>
    <link>http://www.ceglieincucina.com/ita/ricette/ricetta.asp?iData=262&iCat=78</link>
  </image>
  <item>
<title><![CDATA[Carciofi fritti]]></title>
<link>http://www.ceglieincucina.com/ita/ricette/ricetta.asp?iData=262&iCat=78</link>
<description><![CDATA[Preparare dei carciofi avendo cura di togliere tutte le foglie più dure e fibrose e di prenderne il cuore, tagliarli in 4 pezzi e metterli in acqua e limone affinché non diventino subito scuri...]]></description>
<author>Ricette - CeglieInCucina.Com</author>
<pubDate>5 Nov 2009 11:12:54</pubDate>
<category domain="http://www.ceglieincucina.com/ita/ricette/ricetta.asp?iData=262&iCat=78">Ricette</category>
<guid isPermaLink="true">http://www.ceglieincucina.com/ita/ricette/ricetta.asp?iData=262&iCat=78</guid>
</item>

 </channel>
</rss>
In sintesi e straordinario questo xml, mi da come problema quando inserisco questa specie di link in asp,

http://www.ceglieincucina.com/ita/ri...ta=262&iCat=78

mentre se devo linkare link alla quale non c'è questo segno & alla quale ti spiegavo prima non mi funziona.

Tutto quì se ci sono ancora problemi sparati in una gamba "Scherzo"
Ciao Ciao