impostazioni del server locale

iacoposk8

Utente Attivo
21 Apr 2009
54
0
0
ciao a tutti... ho trovato uno script per il login che al momento della registrazione invia una mail d conferma, l'ho provato su apache (ho ubuntu) ma la mail non arriva.. il problema da quel che ho capito sta in qualche configurazione...quindi: volevo sapere se mi potete spiegare cosa cambiare affinchè si possa inviare le mail, e se mi potete passare uno script semplicissimo che invia la mail... anche un semplice form dove mettere l'indirizzo mail che invii un semplice ciao.

la seconda domanda è più generale siccome ho scaricato parecchi script per l'upload dei file e tutti gli script al posto che fare l'upload mi fanno il download della pagina php... che può essere??? anche qua qualche impostazine???

grazie.
 

iacoposk8

Utente Attivo
21 Apr 2009
54
0
0
non c'è nemmeno una guida (italiana) da cui poter leggere? perchè un pò ho cercato ma non è chiaro, se riuscite a spiegarmi sta cose mi fate un favore
grazie
 

iacoposk8

Utente Attivo
21 Apr 2009
54
0
0
si ma c'è di tutto!!! intanto cerco se trovo quel che mi interessa, attendo anche altre risposte più precise
 

iacoposk8

Utente Attivo
21 Apr 2009
54
0
0
io l'ho configurato così:
Codice:
[mail function]
; For Win32 only.
SMTP = localhost
smtp_port = 25

; For Win32 only.
sendmail_from = iacoposk8@libero.it
e lo provo con questo escipt

Codice:
<?
$mail_to = "iacoposk8@libero.it";
$mail_subject = "ciao";
$mail_body = "ciao";
if(mail($mail_to, $mail_subject, $mail_body))
{
	echo "inviata";
}
else
{
	echo "non inviata";
}
?>
ma mi da questo errore:

Warning: mail(): Failed to connect to mailserver at "mail.libero.it" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in c:\programmi\easyphp1-8\www\mail.php on line 8
 

Eliox

Utente Attivo
25 Feb 2005
4.390
3
0
l'errore dovrebbe essere qui:
PHP:
SMTP = localhost
in realtà dovresti indicare l'SMT del tuo provider di connettività, ad esempio con Infostrada:
PHP:
SMTP = mail.libero.it
 

iacoposk8

Utente Attivo
21 Apr 2009
54
0
0
dice ancora
Warning: mail(): Failed to connect to mailserver at "mail.libero.it" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in c:\programmi\easyphp1-8\www\mail.php on line 5
 

iacoposk8

Utente Attivo
21 Apr 2009
54
0
0
si, ma non va, non è che magari mancano punti e virgola o roba di sintassi??
Codice:
[mail function]
; For Win32 only.
SMTP = mail.libero.it  
smtp_port = 25

; For Win32 only.
sendmail_from = iacoposk8@libero.it
poi io cerco da easyphp-->e-->configurazione-->php

giusto???
 

Eliox

Utente Attivo
25 Feb 2005
4.390
3
0
prova a modificare anche il php.ini che sta dentro la cartella Apache, poi riavvia easyPHP e riprova