[HTML] Problemino con le immagini di sfondo

Discussione in 'HTML e CSS' iniziata da Lollo1373, 1 Febbraio 2019.

  1. Lollo1373

    Lollo1373 Nuovo Utente

    Registrato:
    1 Febbraio 2019
    Messaggi:
    4
    Mi Piace Ricevuti:
    0
    Punteggio:
    1
    Buona giornata a tutti.
    Vi scrivo perchè non riesco a risolvere il mio problema (letto varie guide su vari siti e nussuno è riuscito a risolvere il problema):
    Devo mettere una foto di sfondo che mi copra l'intera sezione della pagina senza che "sfasi" (cioè che mi esca dalla pagina visualizzata).

    Questo è il codice html:

    HTML:
    <!doctype html>
    <html>
    
        <head>
            <link href="css/custom.css" rel="stylesheet" type="text/css">
        </head>
    
        <body leftmargin="0" topmargin="0">
          <div id="sfondo">
                    <img src="foto/sfondo.jpg">
                </div>
      </body>
    </html>



    questo invece è il css:

    Codice:
    #sfondo{
      width: 100%;
      height: 100%;
    }
    
    #sfondo img{
      width: 100%;
     height: -webkit-fill-available;
    }
    
    cosa devo fare? per favore aiutatemi
     
    Ultima modifica: 1 Febbraio 2019
  2. Max 1

    Max 1 Super Moderatore Membro dello Staff SUPER MOD MOD

    Registrato:
    29 Febbraio 2012
    Messaggi:
    3.806
    Mi Piace Ricevuti:
    283
    Punteggio:
    83
    Sesso:
    Maschio
    Se ci dai il link per vedere la pagina si capisce meglio quale è il problema
     
  3. Lollo1373

    Lollo1373 Nuovo Utente

    Registrato:
    1 Febbraio 2019
    Messaggi:
    4
    Mi Piace Ricevuti:
    0
    Punteggio:
    1
    non è ancora connesso a server... è tutto in locale (file:///C:/Users/User/Desktop/Sito%202/index.html)
     
  4. Max 1

    Max 1 Super Moderatore Membro dello Staff SUPER MOD MOD

    Registrato:
    29 Febbraio 2012
    Messaggi:
    3.806
    Mi Piace Ricevuti:
    283
    Punteggio:
    83
    Sesso:
    Maschio
    Tu lamenti che l'immagine sborda dalla pagina e che rimane un bordo bianco sotto! Sono due cose contrastanti e senza l'immagine originale non si capisce i problemi e cosa di preciso vuoi dire (almeno io non lo ho capito)!
    Prova ad essere più chiaro e ad allegare l'immagine così almeno proviamo il tuo codice
     
  5. Lollo1373

    Lollo1373 Nuovo Utente

    Registrato:
    1 Febbraio 2019
    Messaggi:
    4
    Mi Piace Ricevuti:
    0
    Punteggio:
    1



    In pratica io devo mettere una foto di sfondo che mi riempe la pagina senza che appaia lo scorrimento laterale per andare su e giu... funziona tutto l'immagine è centrata come la voglio solo che appare un bordino di 2 3 px sotto la foto che fa comparire il menu di scorrimento laterale (quello per andare su e giu che sta a destra anche in questo sito) io devo togliere quel bordo così che questo menu a scorrimento laterale scompaia.
     
Sto caricando...

Condividi questa Pagina