[HTML] Problemi con effetto hover

Andrea_Ventura

Nuovo Utente
10 Giu 2018
24
0
1
Sto cercando di creare una navigation bar, ma riscontro problemi con il background color con l effetto hover. In poche parole la barra si colora parzialmente e non per intero.
Vi allego le foto del codice

Mi sapreste dire cosa devo correggere!?
Grazie in anticipo


Inviato dal mio RNE-L01 utilizzando Tapatalk
 

tess

Nuovo Utente
20 Dic 2017
47
4
8
30
FG
Ciao, ad occhio e croce ti suggerisco di aggiungere la proprietà display: block al tag <a>, così:
Codice:
#navbar li a { display: block; }
Fammi sapere se funziona...
 

tess

Nuovo Utente
20 Dic 2017
47
4
8
30
FG
Probabilmente dovrai cambiare anche la proprietà display del tag <li> in display: block...
 

Andrea_Ventura

Nuovo Utente
10 Giu 2018
24
0
1
No guarda mi spiace, ma così facendo perdo la proprietà incline e inoltre non ottengo il tag a con hover che ricopre completamente il div in ampiezza e larghezza

Inviato dal mio RNE-L01 utilizzando Tapatalk
 

tess

Nuovo Utente
20 Dic 2017
47
4
8
30
FG
A che ti serve inline? Posta il link alla pagina così posso vedere com'è...
 

Max 1

Super Moderatore
Membro dello Staff
SUPER MOD
MOD
29 Feb 2012
3.939
294
83
@Andrea_Ventura
Da regolamento del forum, come tutti noi sei tenuto ad usare il tag
code.gif
quando posti del codice, oppure la funzione codice dalla barra degli strumenti
box inserisci 2.png.JPG

Non usare assolutamente immagini per inserire codice perchè diventa difficoltoso da leggere e molti rinunciano ad aiutarti io per primo!

Inoltre ti prego di leggere attentamente il regolamento generale del forum e quello di sezione dove posti
Grazie