HTACCESS e MOD_REWRITE su Aruba

Discussione in 'Hosting' iniziata da voldemort, 8 Novembre 2012.

  1. voldemort

    voldemort Utente Attivo

    Registrato:
    26 Marzo 2009
    Messaggi:
    162
    Mi Piace Ricevuti:
    5
    Punteggio:
    0
    Salve a tutti,
    Ho acquistato un hosting Linux su Aruba e vorrei crearci un piccolo sito ad uso personale fatto in PHP+MySQL
    Qualcuno sa dirmi se su Aruba è possibile configurare le URL SEO FRIENDLY attraverso HTACCESS??
    Ho provato a caricare il file ".htaccess" ma non funziona nulla... sbaglio qualcosa?
     
  2. cabio

    cabio Nuovo Utente

    Registrato:
    19 Novembre 2012
    Messaggi:
    3
    Mi Piace Ricevuti:
    0
    Punteggio:
    0

    Si certo, é possibile... Posta il contenuto del tuo htaccess che vediamo dove sta il problema.. :)
     
  3. tantrahost.com

    tantrahost.com Utente Attivo

    Registrato:
    16 Ottobre 2012
    Messaggi:
    53
    Mi Piace Ricevuti:
    0
    Punteggio:
    0
    Occupazione:
    Hosting provider
    Località:
    Firenze
    Home Page:
    perchè non provi a contattare l'assistenza? Saranno certamente in grado di aiutarti.
     
  4. SebaGravi

    SebaGravi Nuovo Utente

    Registrato:
    4 Aprile 2017
    Messaggi:
    6
    Mi Piace Ricevuti:
    0
    Punteggio:
    1
    Ciao a tutti,
    Anche io stesso identico problema, anzitutto, ho controllato con phpinfo() se nella pagina ci fosse il mod_rewrite e con la ricerca nella pagina non l'ho trovato eppure anche io ho aruba con hosting linux, credo che di default non sia attivo, ma in ogni caso il modulo caricato lo ho nel mio server mamp su mac, ma il mio .htaccess non funziona lo stesso, ho questo scenario:

    Voglio trasformare la seguente url:
    http://www.miosito.it/news.php?titolo=ciao-mondo-come-stai
    in:
    http://www.miosito.it/news/ciao-mondo-come-stai.html
    ma non funziona, io ho questo .htaccess:

    RewriteEngine On
    RewriteRule ^news/([A-Za-z0-9-]+)\.html$ news.php?titolo=$1 [L]

    a quanto pare dovrebbe essere giusto... ma niente, non funziona, nemmeno in locale dove il mod_rewrite appare sotto la dicitura modulerà leader.
    Boh ci sto diventando matto e non riesco a venirne a capo, ho provato anche con RewriteBase / ma niente, con Option +FollowSymLinks niente lo stesso. pare che nonostante il mod_rewrite abilitato, le chiamate a rewrite non vengano prese in considerazione da apache.
     
  5. the_jurgs

    the_jurgs Nuovo Utente

    Registrato:
    6 Aprile 2017
    Messaggi:
    16
    Mi Piace Ricevuti:
    1
    Punteggio:
    3
    Controlla il file di configurazione di apache.
    Cerca un blocco simile a questo
    <Directory /var/www/>
    Options Indexes FollowSymLinks AllowOverride None
    Require all granted
    </Directory>

    Modifica AllowOverride None in AllowOverride All

    Dovrebbe funzionare

    Inviato dal mio ONE A2003 utilizzando Tapatalk
     
  6. SebaGravi

    SebaGravi Nuovo Utente

    Registrato:
    4 Aprile 2017
    Messaggi:
    6
    Mi Piace Ricevuti:
    0
    Punteggio:
    1
    Ciao, con aruba non ho la possibilità di editare il file di configurazione httpd, quindi se in locale non mi funziona non mi interessa, era per fare solo delle prove, ma tanto se non mi funziona in remoto perché non ho il mod_rewrite abilitato non mi serve a niente fare le prove, spero che mi rispondano al ticket in positivo e che mi attivino questo modulo...
     
Sto caricando...

Condividi questa Pagina