eliminare i propri accessi dalle statistiche di Google Analytic

ferdi74

Utente Attivo
2 Ago 2008
47
0
0
ciao a tutti..come ho scritto nel titolo io sto cercando di eliminare i miei accessi dalle statistiche di Google Analytic sul mio sito..avendo un
IP dinamico non ho potuto utilizzare il semplice filtro sugli IP..ma seguendo una guida ho creato una pagina che attiva un cookie che ha questo codice

<html>
<head>
<script type="text/javascript"
src="http://www.google-analytics.com/ga.js"></script>
<script type="text/javascript">
var pageTracker = _gat._getTracker("UA-XXXXX-X");
pageTracker._initData();
pageTracker._setVar("traffico_interno");
</script>
</head>
<body onload="pageTracker._setVar('traffico_interno')">
<h1>Il cookie è stato impostato</h1>
</body>
</html>

dove al posto di UA-xxxxx-x ho inserito i miei numeretti prelevati dal codice di anlytic inserito nelle mie pagine...

sono entrato in analytic ed ho impostato un filtro in questo modo:

Nome filtro: nome-a-piacere-sensato
Tipo filtro: Filtro personalizzato > Escludi
Campo filtro: Definito dall'utente
Pattern filtro: traffico_interno
Maiuscole/minuscole: No

poi ho caricato la pagina sul server ( mi sono assicurato di avere i js abilitati su tutti i vari browser con cui mi collego ) e sono andato a visitare la pagina dai vari browser per attivare il cookie..

ho anche creato una pagina inutile chiamata "test interno" per verificare se quando ci vado mi viene o meno nelle statistiche.. e un file robots.txt per non far indicizzare queste due pagine..questo è il robots:

User-Agent: *
Disallow: /test-interno.html
Disallow: /escludimi_da_ga.html

infine sono andato dai vari browser a visitare la mia paginina "test interno" ( tutto questo ieri mattina nel giro di un'oretta )
e la sera dopo mezzanotte..quando analytic aggiorna il traffico del giorno appena finito sono andato a controllare e purtroppo la mia paginina "test interno" era lì..quindi continuo a generare traffico..qualcuno sa dirmi se ho sbagliato?..dove ho sbagliato?..ed eventualmente come posso risolvere?..grazie..
 

NewsFlash

Nuovo Utente
12 Ott 2008
11
0
0
www.newsflash.it
CIao ferdi74,
prova a cambiare il tipo di filtro in "Escludi tutto il traffico proveniente da un indirizzo IP". Poi basta inserire il tuo IP nel formato: "^12\.34\.56\.789$".
Da me funziona perfettamente!!! :D
 

ferdi74

Utente Attivo
2 Ago 2008
47
0
0
ciao..ti ringrazio per la risposta..;-)..cmq ho risolto..grazie ciao..:byebye:
 

ferdi74

Utente Attivo
2 Ago 2008
47
0
0
ciao..segui tutta la procedura che ho postato su..è quella giusta..a me non funzionava perche non avevo disattivato il filtro che avevo creato in precedenza ( quello sull'IP) disattivandolo e lasciando sollo quello della procedura esposta su funziona tutto..;-)..ciao e buon lavoro..:fonzie: