Disabilitare gli short open tag con .htaccess

xshell

Nuovo Utente
17 Lug 2008
20
0
0
Buongiorno a tutti.

Ho un problema con i tag minimi di php "<?", perché utilizzo anche xml... Vorrei quindi disabilitarli, però il mio host permette di accedere alle configurazioni solo tramite .htaccess. Non ho mai utilizzato questi file... Potreste aiutarmi?

Ringrazio in anticipo per le risposte.
 

xshell

Nuovo Utente
17 Lug 2008
20
0
0
Ti ringrazio, però non era quello che cercavo... in quel topic si parla su come proteggere le pagine PHP, non come disabilitare i tag corti <? e permettere solo i tag del tipo
<?php... Usando XML abbinato al PHP, per la somiglianza dei tag iniziali, il parser PHP analizza il mio codice XML come se fosse PHP e quindi genera un errore tale da non permettermi di visualizzare la pagina né, a maggior ragione, di usare i tag XML che ho personalizzato... L'host non mi permette di configurare direttamente i file per le impostazioni di PHP e Apache, ma abilita, in un certo senso, la creazione di file .htaccess (anche se con limitazioni)... quindi, ho semplicemente creato il file .htaccess nella cartella principale del sito e ho scritto questa semplice riga di codice (che ho trovato su internet):

php_flag short_open_tag off (che dovrebbe servire per disabilitare i tag corti del PHP...)

La domanda è quindi: ho sbagliato la sintassi, il comando è errato, ho dimenticato qualche cosa oppure è il sito che non permette di farlo? (ho provato a chiedere al servizio di supporto dell'host, ma non ho ricevuto risposta...)
 
Ultima modifica:

Trogo

Utente Attivo
11 Gen 2008
370
0
0
39
Sanremo
La sintassi del comando è corretta. Ci può essere un problema di permessi a livello di configurazione di Apache.
Per la directory dove metti il file .htaccess, deve essere impostato almeno AllowOverride Options.

Una cosa di questo tipo:

Codice:
<VirtualHost *:80>
    ServerAdmin webmaster@tuodominio.it
    DocumentRoot "/home/vhost/tuodominio.it/htdocs"
    ServerName www.tuodominio.it
    ErrorLog "logs/tuodominio.it-error.log"
    CustomLog "logs/tuodominio.it-access.log" common
    php_admin_value open_basedir "/home/vhost/tuodominio.it"
    <Directory "/home/vhost/tuodominio.it">
        AllowOverride Options
    </Directory>
</VirtualHost>
Ma questa ovviamente è una configurazione di competenza dei sistemisti (che non hanno risposto). Magari se gli dici esattamente cosa devono fare, è più facile che ti diano retta...