Come smistare traffico tra rete locale e vpn

Discussione in 'Reti LAN e Wireless' iniziata da mandrake_2, 7 Marzo 2018.

Tag (etichette):
  1. mandrake_2

    mandrake_2 Nuovo Utente

    Registrato:
    3 Marzo 2018
    Messaggi:
    2
    Mi Piace Ricevuti:
    0
    Punteggio:
    1
    Sesso:
    Maschio
    Ciao a tutti,
    lavoro per una società di informatica e sono dislocato presso il cliente e, quindi, durante il lavoro uso la rete del cliente (disponibile sia tramite cavo che tramite wifi). Inoltre per diverse ragioni (limitazioni di traffico imposte dal cliente, risorse della mia azienda accessibili solo dalla intranet aziendale etc...), utilizzo anche la vpn aziendale.
    In pratica la mia necessità è quella di usare la vpn aziendale per uscire su internet ad eccezione di alcuni indirizzi, per i quali deve essere usata la intranet del cliente.
    Per ottenere tutto questo, ho fatto quanto segue:
    • con "route add -p" ho aggiunto le due rotte statiche (permanenti) per specificare la classe di indirizzi per i quali usare la rete del cliente (in sintesi, usa la rete del cliente per tutti i 172.17.17.* e per tutti i 10.1.*.*)
      • rotta #1 - Indirizzo:172.17.17.0, Mask: 255.255.255.0, Gtw: 10.1.86.1, Metrica: 1
      • rotta #2 - Indirizzo:10.1.0.0, Mask: 255.255.255.0, Gtw: 10.1.86.1, Metrica: 1
    • usando prevalentemente Chrome, ho installato il plug-in "Proxy Switch" che mi ha consentito di specificare il proxy aziendale (proxy.aziendale.it:3128), il proxy del cliente (proxy.cliente.it:80), le utenze per entrambi e le regole sugli url per dirigere il traffico su uno o sull'altro
    Tutto questo ha funzionato fino a qualche giorno fa.
    Perchè?
    Perchè nonostante tutto questo, nonostante funzionasse alla perfezione, c'era un url di una risorsa del cliente che non ne voleva sapere di seguire queste regole e, quindi, per poterlo raggiungere mi toccava usare IE nel quale c'era scolpito solo e direttamente il proxy del cliente.
    Quindi ho iniziato a fare prove su prove e, come sempre succede, alla fine mi sono perso (non so più tornare indietro) e, inoltre, non mi funziona più nemmeno tutto il resto.
    Ora, nonostante abbia mantenuto le rotte statiche e le configurazioni del plug-in di Chrome, se mi serve navigare nella rete del cliente mi tocca staccare la vpn aziendale e riattaccarla per tutto il resto.
    E questo si riflette non solo sul browser ma anche sugli altri sw che ho sempre usato (SoapUI, PL\SQL Dev etc...).
    Inoltre ho notato che se provo a fare il ping di una risorsa del cliente succede questo:
    • con la vpn staccata, il nome della risorsa viene risolto correttamente con l'ip locale
    • con la vpn connessa, il nome della risorsa viene risolto con un improbabile 173.45.161.113
    Stesso discorso vale per il tracert.
    Con la vpn connessa, si vede chiaramente che passa per la rete aziendale, mentre se la vpn è disconnessa, passa per la rete del cliente

    Sto ammattendo....
     
    Ultima modifica: 7 Marzo 2018
Sto caricando...

Condividi questa Pagina