730 precompilato + di uno snippet

marino51

Utente Attivo
28 Feb 2013
2.654
134
63
Lombardia
quindi dovrebbe essere così ?

Codice:
<doc:idRimborsoDocumentoFiscale>
    <doc:dataEmissione>2020-01-09</doc:dataEmissione>

    <doc:DocumentoSpesa>
        <doc:dataEmissione>2020-01-05</doc:dataEmissione>

        <doc:dataPagamento>2020-01-08</doc:dataPagamento>
ovvero ho rimborsato il giorno 9 ciò che é stato pagato il giorno 8 per il documento emesso il giorno 5
 

claudio56

Utente Attivo
20 Gen 2016
24
0
1
Ciao Marino,
è da parecchio che non ci sentiamo per le spese sanitarie (2015/2016). Le routines in php da te create non hanno mai dato problemi finora. Ora che devo inviare le spese per l'anno 2019 sto avendo problemi. Leggendo uno degli ultimi posts ho notato che l'AdE ha utilizzato il protocollo TLS 1.2 che con la versione 5.4.41 dava problemi a causa della versione obsoleta di openssl. Ho quindi installato la versione 5.6.31 da te consigliata ed apportate le modifiche a "$SoapClientParam". Non ho più il problema di interruzione connessione generata dal server ma ho il problema di credenziali invalide. Utilizzso l'area Test con credenziali del MEDICO.
Il seguente è l'errore che ricevo
[15-Jan-2020 12:03:33 UTC] PHP Fatal error: Uncaught SoapFault exception: [env:Client] Credenziali invalide in C:\sistemaTS\FattureInviaWsdl.php:49
Stack trace:
#0 C:\sistemaTS\FattureInviaWsdl.php(49): SoapClient->__call('inviaFileMtom', Array)
#1 C:\sistemaTS\FattureInviaWsdl.php(49): SoapClient->inviaFileMtom(Array)
#2 {main}
thrown in C:\sistemaTS\FattureInviaWsdl.php on line 49
Se vuoi ti servono ti invio i files php.
Ciao
Claudio
 

claudio56

Utente Attivo
20 Gen 2016
24
0
1
usa la versione 5.6.31 di php ed usa gli script del 730 senza apportare modifiche
Ho lanciato gli script non modificati utilizzando la versione php 5.6.31 utilizzando come area test il commercialista. in allegato includo i files php originali ed il log ed il file dati per dargli un'occhiata .
Claudio
 

Allegati

marino51

Utente Attivo
28 Feb 2013
2.654
134
63
Lombardia
sembra che lo script venga eseguito con un parametro incompleto
Codice:
PHP Notice:  Undefined offset: 1 in C:\remgest12\prog\sistemaTS\credenziali.php on line 124
conviene rendere non operativa l'ultima riga delle "credenziali"
Codice:
// if( !empty( $argv ) ) $protocollo = $argv[1];
la versione di php in uso NON é la 5.6.31
Codice:
PHP Fatal error:  SOAP Fault: (faultcode: HTTP, faultstring: Could not connect to host)
 

claudio56

Utente Attivo
20 Gen 2016
24
0
1
usa la versione 5.6.31 di php ed usa gli script del 730 senza apportare modifiche
sembra che lo script venga eseguito con un parametro incompleto
Codice:
PHP Notice:  Undefined offset: 1 in C:\remgest12\prog\sistemaTS\credenziali.php on line 124
conviene rendere non operativa l'ultima riga delle "credenziali"
Codice:
// if( !empty( $argv ) ) $protocollo = $argv[1];
la versione di php in uso NON é la 5.6.31
Codice:
PHP Fatal error:  SOAP Fault: (faultcode: HTTP, faultstring: Could not connect to host)
Ciao Marino,
l'ultima riga delle credenziali la utilizzo per passare il numero di protocollo per prelevare le ricevute.
E comunque uso la versione 5.6.31 di php com puoi vedere dal file con i dati generati phpinfo in allegato.
Tu riesci a far eseguire l'invio senza problemi?
Grazie sempre
Claudio
 

Allegati

perseoclub

Utente Attivo
28 Nov 2015
74
0
6
nel 2019 era andato tutto a buon fine..

2020 PANICO!

Codice:
...
...

INIZIO TRASFERIMENTO DEL FILE

REQUEST HEADERS ============
<pre class='xdebug-var-dump' dir='ltr'>
<small>/var/www/html/730_2019/FattureInviaWsdl.php:65:</small><small>string</small> <font color='#cc0000'>'POST /InvioTelematicoSS730pMtomWeb/InvioTelematicoSS730pMtomPort HTTP/1.1&#13;&#10;Host: invioSS730pTest.sanita.finanze.it&#13;&#10;Connection: Keep-Alive&#13;&#10;User-Agent: PHP-SOAP/7.0.33-14+ubuntu16.04.1+deb.sury.org+1&#13;&#10;Content-Type: text/xml; charset=utf-8&#13;&#10;SOAPAction: &quot;&quot;&#13;&#10;Content-Length: 253&#13;&#10;Authorization: Basic VVhONlZNREQ6UDJTUERWRjQ=&#13;&#10;Cookie: LtpaToken2=Fcs3UNDKxy/EuuuRWsoP0Y9I3bADs0N1fbUm0rjVRGoLCouYZc3Ewdde4e8L9eycLFN+yQJP6g/xF7GfH77oQv//idq8CC26t7j0b0EovW4+GMPXOhyXETfzj6an1mg+unEV2qjnVYqeBmx8IE1cAawknWgEtqo5qN8P5Z5hu'...</font> <i>(length=732)</i>
</pre>


REQUEST ====================
<pre class='xdebug-var-dump' dir='ltr'>
<small>/var/www/html/730_2019/FattureInviaWsdl.php:69:</small><small>string</small> <font color='#cc0000'>'&lt;?xml version=&quot;1.0&quot; encoding=&quot;UTF-8&quot;?&gt;&#10;&lt;SOAP-ENV:Envelope xmlns:SOAP-ENV=&quot;http://schemas.xmlsoap.org/soap/envelope/&quot; xmlns:ns1=&quot;http://ejb.invioTelematicoSS730p.sanita.finanze.it/&quot;&gt;&lt;SOAP-ENV:Body&gt;&lt;ns1:inviaFileMtom/&gt;&lt;/SOAP-ENV:Body&gt;&lt;/SOAP-ENV:Envelope&gt;&#10;'</font> <i>(length=253)</i>
</pre>


RESPONSE HEADERS ===========
<pre class='xdebug-var-dump' dir='ltr'>
<small>/var/www/html/730_2019/FattureInviaWsdl.php:73:</small><small>string</small> <font color='#cc0000'>'HTTP/1.1 500 Internal Server Error&#13;&#10;Content-Type: text/xml&#13;&#10;X-Backside-Transport: FAIL FAIL&#13;&#10;Connection: close&#13;&#10;'</font> <i>(length=112)</i>
</pre>


RESPONSE ===================
<pre class='xdebug-var-dump' dir='ltr'>
<small>/var/www/html/730_2019/FattureInviaWsdl.php:77:</small><small>string</small> <font color='#cc0000'>'&lt;?xml version=&quot;1.0&quot; encoding=&quot;UTF-8&quot;?&gt;&#10;&#10;&lt;env:Envelope xmlns:env=&quot;http://schemas.xmlsoap.org/soap/envelope/&quot;&gt;&#10;&lt;env:Body&gt;&#10;&lt;env:Fault&gt;&#10;&lt;faultcode&gt;env:Client&lt;/faultcode&gt;&#10;&lt;faultstring&gt;cvc-particle 3.1: in element {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom of type {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom, found &amp;lt;/ns1:inviaFileMtom&gt; (in namespace http://ejb.invioTelematicoSS730p.sanita.finanze.it/), but next item should be nomeFileAllegato&lt;/faultstring&gt;&lt;/env:Fau'...</font> <i>(length=541)</i>
</pre>


TRASFERIMENTO TERMINATO CON ERRORI

SOAP Fault: (faultcode: env:Client, faultstring: cvc-particle 3.1: in element {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom of type {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom, found (in namespace http://ejb.invioTelematicoSS730p.sanita.finanze.it/), but next item should be nomeFileAllegato)

/var/www/html/730_2019/FattureInviaWsdl.php:93:
object(SoapFault)[4]
  protected 'message' => string 'cvc-particle 3.1: in element {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom of type {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom, found </ns1:inviaFileMtom> (in namespace http://ejb.invioTelematicoSS730p.sanita.finanze.it/), but next item should be nomeFileAllegato' (length=307)
  private 'string' (Exception) => string '' (length=0)
  protected 'code' => int 0
  protected 'file' => string '/var/www/html/730_2019/FattureInviaWsdl.php' (length=43)
  protected 'line' => int 80
  private 'trace' (Exception) =>
    array (size=1)
      0 =>
        array (size=6)
          'file' => string '/var/www/html/730_2019/FattureInviaWsdl.php' (length=43)
          'line' => int 80
          'function' => string '__call' (length=6)
          'class' => string 'SoapClient' (length=10)
          'type' => string '->' (length=2)
          'args' =>
            array (size=2)
              ...
  private 'previous' (Exception) => null
  public 'faultstring' => string 'cvc-particle 3.1: in element {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom of type {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom, found </ns1:inviaFileMtom> (in namespace http://ejb.invioTelematicoSS730p.sanita.finanze.it/), but next item should be nomeFileAllegato' (length=307)
  public 'faultcode' => string 'env:Client' (length=10)

Aggiungo anche il LOG

Codice:
[20-Jan-2020 12:23:21 Europe/Berlin] File trattato          : Fatture730_2019_completo.zip
[20-Jan-2020 12:23:21 Europe/Berlin] carico in memoria il file Fatture730_2019_completo.zip
[20-Jan-2020 12:23:21 Europe/Berlin] definisco il file wsdl InvioTelematicoSpeseSanitarie730p.wsdl
[20-Jan-2020 12:23:21 Europe/Berlin] definisco the soap server location https://invioSS730pTest.sanita.finanze.it/InvioTelematicoSS730pMtomWeb/InvioTelematicoSS730pMtomPort
[20-Jan-2020 12:23:21 Europe/Berlin] inizio trasferimento del file
[20-Jan-2020 12:23:21 Europe/Berlin] PHP Deprecated:  capture_session_meta is deprecated; its information is now available via stream_get_meta_data() in /var/www/html/730_2019/FattureInviaWsdl.php on line 54
[20-Jan-2020 12:23:22 Europe/Berlin] PHP Notice:  Undefined variable: SoapRequest in /var/www/html/730_2019/FattureInviaWsdl.php on line 80
[20-Jan-2020 12:23:22 Europe/Berlin] PHP Stack trace:
[20-Jan-2020 12:23:22 Europe/Berlin] PHP   1. {main}() /var/www/html/730_2019/FattureInviaWsdl.php:0
[20-Jan-2020 12:23:22 Europe/Berlin] trasferimento terminato con errori
[20-Jan-2020 12:23:22 Europe/Berlin] PHP Fatal error:  SOAP Fault: (faultcode: env:Client, faultstring: cvc-particle 3.1: in element {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom of type {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom, found </ns1:inviaFileMtom> (in namespace http://ejb.invioTelematicoSS730p.sanita.finanze.it/), but next item should be nomeFileAllegato) in /var/www/html/730_2019/FattureInviaWsdl.php on line 94
[20-Jan-2020 12:23:22 Europe/Berlin] PHP Stack trace:
[20-Jan-2020 12:23:22 Europe/Berlin] PHP   1. {main}() /var/www/html/730_2019/FattureInviaWsdl.php:0
[20-Jan-2020 12:23:22 Europe/Berlin] PHP   2. trigger_error() /var/www/html/730_2019/FattureInviaWsdl.php:94
Marino Aiutami tu.. :(
 

marino51

Utente Attivo
28 Feb 2013
2.654
134
63
Lombardia
Tu riesci a far eseguire l'invio senza problemi?
eseguo lo script in questo modo,
Codice:
echo on
"C:\Program Files\PHP\v5.6\php.exe" -f "C:\Web_Sites\__Test\PHP\TEST\XML\FattureInviaWsdl.php"
pause
con la versione 5.4 di php, ottengo lo stesso tuo risultato
Codice:
[20-Jan-2020 12:46:29 Europe/Rome] RICHIESTA TERMINATA CON ERRORE
[20-Jan-2020 12:46:29 Europe/Rome]
e =>object
(
    faultstring => Error Fetching http headers,
    faultcode => HTTP,
)
[20-Jan-2020 12:46:29 Europe/Rome] PHP Fatal error:  SOAP Fault: (faultcode: HTTP, faultstring: Error Fetching http headers) in C:\Web_Sites\__Test\PHP\TEST\XML\SoapFault.php on line 18
con la versione 5.6 il webservice mi risponde

Codice:
[20-Jan-2020 12:50:08 Europe/Rome] RICHIESTA TERMINATA CON ERRORE
[20-Jan-2020 12:50:08 Europe/Rome]
e =>object
(
    faultstring => Credenziali invalide,
    faultcode => env:Client,
)
[20-Jan-2020 12:50:09 Europe/Rome] PHP Fatal error:  SOAP Fault: (faultcode: env:Client, faultstring: Credenziali invalide) in C:\Web_Sites\__Test\PHP\TEST\XML\SoapFault.php on line 18
non badare alle credenziali invalide, non ho un esempio pronto dell'intermediario, l'ho costruito inserendo la sede probabilmente nel punto sbagliato o lasciando zeri dove tu hai messo null,
ma come vedi risponde

potresti mettere all'inizio dell'invio, la stampa della versione php per renderti conto
saluti
 

claudio56

Utente Attivo
20 Gen 2016
24
0
1
eseguo lo script in questo modo,
Codice:
echo on
"C:\Program Files\PHP\v5.6\php.exe" -f "C:\Web_Sites\__Test\PHP\TEST\XML\FattureInviaWsdl.php"
pause
con la versione 5.4 di php, ottengo lo stesso tuo risultato
Codice:
[20-Jan-2020 12:46:29 Europe/Rome] RICHIESTA TERMINATA CON ERRORE
[20-Jan-2020 12:46:29 Europe/Rome]
e =>object
(
    faultstring => Error Fetching http headers,
    faultcode => HTTP,
)
[20-Jan-2020 12:46:29 Europe/Rome] PHP Fatal error:  SOAP Fault: (faultcode: HTTP, faultstring: Error Fetching http headers) in C:\Web_Sites\__Test\PHP\TEST\XML\SoapFault.php on line 18
con la versione 5.6 il webservice mi risponde

Codice:
[20-Jan-2020 12:50:08 Europe/Rome] RICHIESTA TERMINATA CON ERRORE
[20-Jan-2020 12:50:08 Europe/Rome]
e =>object
(
    faultstring => Credenziali invalide,
    faultcode => env:Client,
)
[20-Jan-2020 12:50:09 Europe/Rome] PHP Fatal error:  SOAP Fault: (faultcode: env:Client, faultstring: Credenziali invalide) in C:\Web_Sites\__Test\PHP\TEST\XML\SoapFault.php on line 18
non badare alle credenziali invalide, non ho un esempio pronto dell'intermediario, l'ho costruito inserendo la sede probabilmente nel punto sbagliato o lasciando zeri dove tu hai messo null,
ma come vedi risponde

potresti mettere all'inizio dell'invio, la stampa della versione php per renderti conto
saluti
Ciao Marino, sto ammattendo letteralmente con l'area test.
Se uso le credenziali commercialista che postato in precedenza ottengo credenziali non valide, mentre se utilizzo le credenziali dello psicologo che allego ottengo l'errore di collegamento all'host.
Ci capisci qualcosa?
Come posso fare a vedere i dati di richiesta collegamento al server? (Nome utente e pwd per intenderci?
Grazie
Claudio
 

Allegati

marxvilly

Nuovo Utente
21 Nov 2017
5
0
1
46
Buonasera,
ho ricevuto una richiesta di modifica dell'invio dei dati al sistema TS. In pratica pare che per quest'anno sia necessario indicare anche se il pagamento è tracciato.
Qualcuno ha già affrontato il problema su come inviarlo tramite il file xml?
Grazie mille!
 

marino51

Utente Attivo
28 Feb 2013
2.654
134
63
Lombardia
Se uso le credenziali commercialista che postato in precedenza ottengo credenziali non valide
le ho copiate dal tuo script e ottengo lo stesso risultato ( con php 5.6.31 come detto )

credo sia necessario recuperare le credenziali, ho documentazione vecchia che riporta esattamente i valori usati, probabile che nel tempo le abbiano cambiate
 

marino51

Utente Attivo
28 Feb 2013
2.654
134
63
Lombardia
request headers é molto strano,
vi sono all'interno caratteri CR e LF che non dovrebbero esserci,
vi sono tag html, campi vuoti,
é una visualizzazione o é il pacchetto di dati trasmesso ??
Codice:
REQUEST HEADERS ============
<pre class='xdebug-var-dump' dir='ltr'>
<small>/var/www/html/730_2019/FattureInviaWsdl.php:65:</small>
<small>string</small>
<font color='#cc0000'>
'POST /InvioTelematicoSS730pMtomWeb/InvioTelematicoSS730pMtomPort HTTP/1.1
&#13;
&#10;
Host: invioSS730pTest.sanita.finanze.it
&#13;
&#10;
Connection: Keep-Alive
&#13;
&#10;
User-Agent: PHP-SOAP/7.0.33-14+ubuntu16.04.1+deb.sury.org+1
&#13;
&#10;
Content-Type: text/xml;
charset=utf-8
&#13;
&#10;
SOAPAction: &quot;&quot;
&#13;
&#10;
Content-Length: 253
&#13;
&#10;
Authorization: Basic VVhONlZNREQ6UDJTUERWRjQ=
&#13;
&#10;
Cookie: LtpaToken2=Fcs3UNDKxy/EuuuRWsoP0Y9I3bADs0N1fbUm0rjVRGoLCouYZc3Ewdde4e8L9eycLFN+yQJP6g/xF7GfH77oQv//idq8CC26t7j0b0EovW4+GMPXOhyXETfzj6an1mg+unEV2qjnVYqeBmx8IE1cAawknWgEtqo5qN8P5Z5hu'...</font> <i>(length=732)</i>
</pre>
si dovrebbe leggere così,
Codice:
REQUEST HEADERS ============
string(712) "
POST /InvioTelematicoSS730pMtomWeb/InvioTelematicoSS730pMtomPort HTTP/1.1
Host: invioSS730pTest.sanita.finanze.it
Connection: Keep-Alive User-Agent:
PHP-SOAP/5.6.40
Content-Type: text/xml;
charset=utf-8
SOAPAction: ""
Content-Length: 253
Authorization: Basic UFJPVkFYMDBYMDBYMDAwWTpTYWx2ZTEyMw==
Cookie: LtpaToken2=K3MJG/aHhM3Wivlzq4NXNBKXbBQiiZXPDlyBqy0ruZjIhBW/fAExPvj4+eDz/duutPPZgTSkWhDvlX8mKiGK2E/iPSMl+llzlUheBdGUlwIVKK8BC0cV6/47m3ITEi3nM/k4HD10oJH5bCyUKBqlvnYHv7OKlpW8q60yMiiZK/xO6kQ8wo8C7YTOUk0xJeEGU7Tdq5ZXjCLD+qAAVd/E9Ns+p2jGUGwdzNfCYPh4epQcgY/jPve7vjHPqK6w0vVtvaYsu2vf8x8NOCKdOjHuUHkELpaODe0EySaG9z9MXB9vsNScQoBg7foBRALvt4uM0tVq7Njtw4mkgkHiUS27Y9Ds8ndUvR+DDS9WIx+LoVXWH2gLD+4GmjDtqOYqNA1m; "
 

marino51

Utente Attivo
28 Feb 2013
2.654
134
63
Lombardia
sto ammattendo letteralmente con l'area test.
vedi che le buone letture servono,

Codice:
[20-Jan-2020 20:37:36 Europe/Rome] INIZIO TRASFERIMENTO DEL FILE
[20-Jan-2020 20:37:36 Europe/Rome]
SoapRequest => array
(
    [pincodeInvianteCifrato] => 4B64AA1D,
    [datiProprietario] => array
    (
        [cfProprietario] => FBNFBA62S28H501F,
    ),
    [nomeFileAllegato] => CASELLA_spesesanitarie_19_1.zip,
    [documento] => MAX-LEN,
    [opzionale1] => 07874631000-000,
    [opzionale2] => 0,
    [opzionale3] => 0,
)
[20-Jan-2020 20:37:38 Europe/Rome] L'INVIO HA AVUTO RISPOSTA
[20-Jan-2020 20:37:38 Europe/Rome]
output => object
(
    return => object
    (
        codiceEsito => 0,
        dataAccoglienza => 20-01-2020 20:37:38,
        descrizioneEsito => Il file è in attesa di elaborazione, per conoscerne l'esito è necessario verificare la ricevuta,
        dimensioneFileAllegato => 4051,
        nomeFileAllegato => CASELLA_spesesanitarie_19_1.zip,
        protocollo => 20012020373890467,
        idErrore => empty,
    ),
)
[20-Jan-2020 20:37:38 Europe/Rome] TRASFERIMENTO TERMINATO CON SUCCESSO
[20-Jan-2020 20:37:38 Europe/Rome] done C:\Web_Sites\__Test\PHP\TEST\XML\FattureInviaWsdl.php
pincodeInvianteCifrato NON DEVE ESSERE CIFRATO
l' end point di test devi aggiungere "entrate"
.finanze.it/entrate/InvioTelem
 

perseoclub

Utente Attivo
28 Nov 2015
74
0
6
request headers é molto strano,
vi sono all'interno caratteri CR e LF che non dovrebbero esserci,
vi sono tag html, campi vuoti,
é una visualizzazione o é il pacchetto di dati trasmesso ??
Ho fatto copia/incolla della stampa a video restituita dalla funzione envelopes() che avevi postato qualche pagina fa, nello script "FattureInviaWsdl.php"

Per il resto ho aggiunto nello script "Credenziali.php" il seguente codice:
PHP:
$SoapClientParam = array(
    "location"       => "x",
    "login"          => $login,
    "password"       => $password,
    "authentication" => SOAP_AUTHENTICATION_BASIC,
    "trace"          => true,
    "exceptions"     => false,
    "stream_context" => stream_context_create(
        array(
            "ssl" => array(
                "verify_peer"          => FALSE,
                "verify_peer_name"     => FALSE,
                "capture_session_meta" => TRUE,
            )
        )
    )
);
..come modificato da msccmra51, perché anche a me il tuo dava errore e si arrestava lo script.

Ho usato gli script degli anni precedenti, senza modificare null'altro.


------------------------------------------------------------------------------------------------------
PS:

Quando ho settato $SoapClientParam come l'avevi postata tu, il LOG mi restituiva questo listato:
Codice:
[21-Jan-2020 00:30:29 Europe/Berlin] .
[21-Jan-2020 00:30:29 Europe/Berlin] main /730_2019/FattureInviaWsdl.php
[21-Jan-2020 00:30:29 Europe/Berlin] TEST RUN ***************
[21-Jan-2020 00:30:29 Europe/Berlin] name                   : Laboratorio Valle d'Aosta 020-101-888888
[21-Jan-2020 00:30:29 Europe/Berlin] login                  : UXN6VMDD
[21-Jan-2020 00:30:29 Europe/Berlin] password               : P2SPDVF4
[21-Jan-2020 00:30:29 Europe/Berlin] cfProprietario         : CCSRMO77A09H501E
[21-Jan-2020 00:30:29 Europe/Berlin] cfProprietarioCifrato  : wzOpollrYgV+ILDD8h6s6yPQjfNZQrs0mKJjIaVAYE8avxTIi9ZJrzS385FEgcvWukoA7o20C1amHOsN7n4huuvS9Y63HC9c6moDEqCj2G1qpnKT/eU3NuUmgvuLrHxgFbSZKohbi3Oyrl+wprcx0PnikiEutQm/sHFFWuZGmN8=
[21-Jan-2020 00:30:29 Europe/Berlin] piProprietario         : 03213213210
[21-Jan-2020 00:30:29 Europe/Berlin] pincodeInviante        : 1426073406
[21-Jan-2020 00:30:29 Europe/Berlin] pincodeInvianteCifrato : txIO+4Z3DqZvxrol9o6KmkQjlWSD4SOLdeUigRadhoxVNv7rM3RytJlT1jCHdMEg337cD3D1bvYd/uFLeBT+uZzzZy67Rx5UlWD6bvqXlRQjAMxDH/oGcsxmLtBqLPe8i/ZHdiE1xgEPWj+OX6bOdZJOaQgCa9LY8WQaWOWSvbA=
[21-Jan-2020 00:30:29 Europe/Berlin] File trattato          : Fatture730_2019_completo.zip
[21-Jan-2020 00:30:29 Europe/Berlin] carico in memoria il file Fatture730_2019_completo.zip
[21-Jan-2020 00:30:29 Europe/Berlin] definisco il file wsdl InvioTelematicoSpeseSanitarie730p.wsdl
[21-Jan-2020 00:30:29 Europe/Berlin] definisco the soap server location https://invioSS730pTest.sanita.finanze.it/InvioTelematicoSS730pMtomWeb/InvioTelematicoSS730pMtomPort
[21-Jan-2020 00:30:29 Europe/Berlin] inizio trasferimento del file
[21-Jan-2020 00:30:29 Europe/Berlin] PHP Deprecated:  capture_session_meta is deprecated; its information is now available via stream_get_meta_data() in /var/www/html/730_2019/FattureInviaWsdl.php on line 54
[21-Jan-2020 00:30:30 Europe/Berlin] PHP Notice:  Undefined variable: SoapRequest in /var/www/html/730_2019/FattureInviaWsdl.php on line 80
[21-Jan-2020 00:30:30 Europe/Berlin] PHP Stack trace:
[21-Jan-2020 00:30:30 Europe/Berlin] PHP   1. {main}() /var/www/html/730_2019/FattureInviaWsdl.php:0
[21-Jan-2020 00:30:30 Europe/Berlin] PHP Fatal error:  Uncaught Error: Call to undefined function LogTitles() in /var/www/html/730_2019/SoapFault.php:4
Stack trace:
#0 /var/www/html/730_2019/FattureInviaWsdl.php(83): require()
#1 {main}
  thrown in /var/www/html/730_2019/SoapFault.php on line 4
 
Ultima modifica:

perseoclub

Utente Attivo
28 Nov 2015
74
0
6
Ho fatto altre prove..

Ho risettato la variabile $SoapClientParam come l'hai postata tu..

Ho aggiunto la funzione envelopes() al file "FattureInviaWsdl.php"

Ho creato il nuovo file "SoapFault.php", aggiungendoci le funzioni:
  • show_var($variable)
  • log_var($value, $max_depth = 99, $key = NULL, $depth = 0, $refChain = array(), $tab = NULL, $text = NULL)
  • LogTitles($string=null, $addtext=null)
Infine ho ridato i permessi a tutti i file.

Quando lancio lo script "FattureInviaWsdl.php" ottengo questa risposta a video:
Codice:
INIZIO TRASFERIMENTO DEL FILE

RICHIESTA TERMINATA CON ERRORE
SOAP Fault: (faultcode: env:Client, faultstring: cvc-particle 3.1: in element {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom of type {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom, found (in namespace http://ejb.invioTelematicoSS730p.sanita.finanze.it/), but next item should be nomeFileAllegato)output
KEY    VALUE
return   
KEY    VALUE
codiceEsito    0
dataAccoglienza    21-01-2020 00:48:48
descrizioneEsito    Il file è in attesa di elaborazione, per conoscerne l'esito è necessario verificare la ricevuta
dimensioneFileAllegato    597301
nomeFileAllegato    Fatture730_2019_completo.zip
protocollo    20012100484893024
idErrore    empty


SoapFault Object ( [message:protected] => cvc-particle 3.1: in element {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom of type {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom, found (in namespace http://ejb.invioTelematicoSS730p.sanita.finanze.it/), but next item should be nomeFileAllegato [string:Exception:private] => [code:protected] => 0 [file:protected] => /var/www/html/730_2019/FattureInviaWsdl.php [line:protected] => 80 [trace:Exception:private] => Array ( [0] => Array ( [file] => /var/www/html/730_2019/FattureInviaWsdl.php [line] => 80 [function] => __call [class] => SoapClient [type] => -> [args] => Array ( [0] => inviaFileMtom [1] => Array ( [0] => ) ) ) ) [previous:Exception:private] => [faultstring] => cvc-particle 3.1: in element {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom of type {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom, found (in namespace http://ejb.invioTelematicoSS730p.sanita.finanze.it/), but next item should be nomeFileAllegato [faultcode] => env:Client [xdebug_message] => ( ! ) SoapFault: cvc-particle 3.1: in element {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom of type {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom, found </ns1:inviaFileMtom> (in namespace http://ejb.invioTelematicoSS730p.sanita.finanze.it/), but next item should be nomeFileAllegato in /var/www/html/730_2019/FattureInviaWsdl.php on line 80 Call Stack #TimeMemoryFunctionLocation 10.0000357232{main}( ).../FattureInviaWsdl.php:0 20.73351801784SoapClient->inviaFileMtom( ).../FattureInviaWsdl.php:80 30.73351802160__call ( ).../FattureInviaWsdl.php:80 )

KEY    VALUE
faultstring    cvc-particle 3.1: in element {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom of type {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom, found (in namespace http://ejb.invioTelematicoSS730p.sanita.finanze.it/), but next item should be nomeFileAllegato
faultcode    env:Client
xdebug_message   
( ! ) SoapFault: cvc-particle 3.1: in element {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom of type {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom, found </ns1:inviaFileMtom> (in namespace http://ejb.invioTelematicoSS730p.sanita.finanze.it/), but next item should be nomeFileAllegato in /var/www/html/730_2019/FattureInviaWsdl.php on line 80
Call Stack
#    Time    Memory    Function    Location
1    0.0000    357232    {main}( )    .../FattureInviaWsdl.php:0
2    0.7335    1801784    SoapClient->inviaFileMtom( )    .../FattureInviaWsdl.php:80
3    0.7335    1802160    __call ( )    .../FattureInviaWsdl.php:80


REQUEST HEADERS ============
<pre class='xdebug-var-dump' dir='ltr'>
<small>/var/www/html/730_2019/SoapFault.php:16:</small><small>string</small> <font color='#cc0000'>'POST /InvioTelematicoSS730pMtomWeb/InvioTelematicoSS730pMtomPort HTTP/1.1&#13;&#10;Host: invioSS730pTest.sanita.finanze.it&#13;&#10;Connection: Keep-Alive&#13;&#10;User-Agent: PHP-SOAP/7.0.33-14+ubuntu16.04.1+deb.sury.org+1&#13;&#10;Content-Type: text/xml; charset=utf-8&#13;&#10;SOAPAction: &quot;&quot;&#13;&#10;Content-Length: 253&#13;&#10;Authorization: Basic VVhONlZNREQ6UDJTUERWRjQ=&#13;&#10;Cookie: LtpaToken2=sYUDS63CHBeXB4PnzIkTUNutvc36arpHmXtY6gTDWWJ6thOG7M74a42Ed7ogAHKZuFFI3HuVQ52LJzUG0E+DMylbhsmbDv4uJRAFeY14dZqOzfOO7kDp4xSM6THMNktcTYC5tNq4ri6jWXy+it0p1STmU+6szvuKigNLGFj74'...</font> <i>(length=732)</i>
</pre>


REQUEST ====================
<pre class='xdebug-var-dump' dir='ltr'>
<small>/var/www/html/730_2019/SoapFault.php:19:</small><small>string</small> <font color='#cc0000'>'&lt;?xml version=&quot;1.0&quot; encoding=&quot;UTF-8&quot;?&gt;&#10;&lt;SOAP-ENV:Envelope xmlns:SOAP-ENV=&quot;http://schemas.xmlsoap.org/soap/envelope/&quot; xmlns:ns1=&quot;http://ejb.invioTelematicoSS730p.sanita.finanze.it/&quot;&gt;&lt;SOAP-ENV:Body&gt;&lt;ns1:inviaFileMtom/&gt;&lt;/SOAP-ENV:Body&gt;&lt;/SOAP-ENV:Envelope&gt;&#10;'</font> <i>(length=253)</i>
</pre>


RESPONSE HEADERS ===========
<pre class='xdebug-var-dump' dir='ltr'>
<small>/var/www/html/730_2019/SoapFault.php:22:</small><small>string</small> <font color='#cc0000'>'HTTP/1.1 500 Internal Server Error&#13;&#10;Content-Type: text/xml&#13;&#10;X-Backside-Transport: FAIL FAIL&#13;&#10;Connection: close&#13;&#10;'</font> <i>(length=112)</i>
</pre>


RESPONSE ===================
<pre class='xdebug-var-dump' dir='ltr'>
<small>/var/www/html/730_2019/SoapFault.php:25:</small><small>string</small> <font color='#cc0000'>'&lt;?xml version=&quot;1.0&quot; encoding=&quot;UTF-8&quot;?&gt;&#10;&#10;&lt;env:Envelope xmlns:env=&quot;http://schemas.xmlsoap.org/soap/envelope/&quot;&gt;&#10;&lt;env:Body&gt;&#10;&lt;env:Fault&gt;&#10;&lt;faultcode&gt;env:Client&lt;/faultcode&gt;&#10;&lt;faultstring&gt;cvc-particle 3.1: in element {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom of type {http://ejb.invioTelematicoSS730p.sanita.finanze.it/}inviaFileMtom, found &amp;lt;/ns1:inviaFileMtom&gt; (in namespace http://ejb.invioTelematicoSS730p.sanita.finanze.it/), but next item should be nomeFileAllegato&lt;/faultstring&gt;&lt;/env:Fau'...</font> <i>(length=541)</i>
</pre>
 

claudio56

Utente Attivo
20 Gen 2016
24
0
1
vedi che le buone letture servono,

Codice:
[20-Jan-2020 20:37:36 Europe/Rome] INIZIO TRASFERIMENTO DEL FILE
[20-Jan-2020 20:37:36 Europe/Rome]
SoapRequest => array
(
    [pincodeInvianteCifrato] => 4B64AA1D,
    [datiProprietario] => array
    (
        [cfProprietario] => FBNFBA62S28H501F,
    ),
    [nomeFileAllegato] => CASELLA_spesesanitarie_19_1.zip,
    [documento] => MAX-LEN,
    [opzionale1] => 07874631000-000,
    [opzionale2] => 0,
    [opzionale3] => 0,
)
[20-Jan-2020 20:37:38 Europe/Rome] L'INVIO HA AVUTO RISPOSTA
[20-Jan-2020 20:37:38 Europe/Rome]
output => object
(
    return => object
    (
        codiceEsito => 0,
        dataAccoglienza => 20-01-2020 20:37:38,
        descrizioneEsito => Il file è in attesa di elaborazione, per conoscerne l'esito è necessario verificare la ricevuta,
        dimensioneFileAllegato => 4051,
        nomeFileAllegato => CASELLA_spesesanitarie_19_1.zip,
        protocollo => 20012020373890467,
        idErrore => empty,
    ),
)
[20-Jan-2020 20:37:38 Europe/Rome] TRASFERIMENTO TERMINATO CON SUCCESSO
[20-Jan-2020 20:37:38 Europe/Rome] done C:\Web_Sites\__Test\PHP\TEST\XML\FattureInviaWsdl.php
pincodeInvianteCifrato NON DEVE ESSERE CIFRATO
l' end point di test devi aggiungere "entrate"
.finanze.it/entrate/InvioTelem
Buon giorno Marino, non so cosa hai fatto ma a me con le stesse credenziali da un errore.
Se guardi attentamente il file credenziali di "CASELLA", nell'end point è già presente "entrate" e dalle seguenti asssegnazioni puoi notare che il pincode dell'inviante non è cifrato.
"
$pincodeInviante = _pincodeInviante;
$pincodeInvianteCifrato = _pincodeInviante;
"
Riallego di nuovo files di test che danno il problema con le stesse credenziali da te usate.
Potresti per caso ripostare il file FattureInviaWsdl.php?
Grazie per la tua pazienza.
Claudio
 

Allegati